Important additional news on our stable release.

Our Spanish member Jinkros informed us that the latest Intel wifi cards don’t work with our ISO, due to a bug with the latest Linux Kernel 5.2.0 -arch2-1-ARCH.

Until now we know it concerns the Intel wifi cardAC 9620. Unfortunately this is an upstream problem and we will keep you informed when this bug is resolved.

Follow us

Related Posts